Oudere generatie PlayStation-games niet speelbaar op PlayStation 5

Er gingen al enige geruchten dat de PlayStation 5 alleen backwards compatibel zal worden met PS4-games, en in een interview met Famitsu heeft Sony CEO Jim Ryan dit bevestigd 

Ondanks dat het interview in het Japans is te lezen, heeft Silliconera het interview vertaald naar de Engelse taal. De eerste vragen in het interview gaan over hoeveel PlayStation 4-games er speelbaar zouden zijn op de PlayStation 5. Hierna kwam de vraag of games van de PlayStation 1, 2 én 3 gaan werken op de PlayStation 5. Hierbij gaf Jim Ryan het volgende antwoord:

We keep in mind the engineering specialized for the PS5, as we produced the device. In the midst of that, the PS4 already has 100 million players; we thought they ought to want to play PS4 titles on the PS5 as well indeed, so we included compatibility with the PS4. While implementing that, we also focused our efforts on taking in the high-speed SSD and the new controller DualSense at the same time. So, unfortunately, we couldn’t reach the implementation of such compatibilities.

Dit houdt dus in dat Sony geen tijd meer had om oudere generatie games backward compatible te maken. Er is wel de mogelijkheid om games van oudere generatie consoles te spelen via de PS Now dienst.

Ook interessant
Ghostrunner krijgt gratis next-gen upgrade in 2021
NL / EN